WordPress安装需要PHP与MySQL版本要求与环境配置事项

  1. 网友热度 12,331 ℃ - 抢沙发
  2. 标签:, ,
  3. 微信公众号: imweber

老左在前几天有分享过"WordPress 5.2版本将于四月底上线且最低需PHP 5.6.20版本"文章,主要是看到WordPress官方网站有提到需要在月底发布5.2版本且需要要求PHP最低5.6版本,也就是说如果我们PHP版本低于这个版本的,可能在新版本到来的时候升级会出现兼容问题。如果我们是这样子的情况肯定需要提前做好准备,因为我们还有不到一个月的时间去升级。

其实我们在WordPress官方网站下载最新版程序的时候,有文档已经提到建议的最佳PHP与MYSQL数据库版本,以及推荐的WEB环境支持。

WordPress安装需要PHP与MySQL版本要求与环境配置事项

We recommend servers running version 7.3 or greater of PHP and MySQL version 5.6 OR MariaDB version 10.0 or greater. We also recommend either Apache or Nginx as the most robust options for running WordPress, but neither is required.

我们可以看到建议是PHP7.3(最新版本是PHP7.3),以及数据库要求最低是MySQL5.6或者MariaDB 10.0,WEB引擎是Nginx或者是Apache,这也是我们大家常用的。这次主要是明确要求PHP的最低版本,其实官方在文章中也有提到:

This is the first increase in PHP required version for WordPress since 2010, but may not be the only increase in 2019. The WordPress core team will monitor the adoption of the most recent versions of PHP with an eye towards making PHP 7+ the minimum version towards the end of the year.

这次PHP升级是版本要求是从2010年以来的第一次,估计在后面会要求PHP7+版本起步,所以如果我们可以的话,建议直接升级到7.0+版本,毕竟从众多网友的测试看在性能上PHP7+之后性能是比较优秀的。不过,前提也需要考虑到我们使用的主题和插件兼容性。

如果我们的服务器中有其他程序需要用到低版本的PHP的话,我们可以考虑在WEB环境中多PHP并存,一般的工具也都可以实现。

本文固定链接: https://www.laozuo.org/13597.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。 公众号:imweber


关注公众号『站长事儿』

获取更多站长圈的新鲜事儿!
有您,有我,还有大家!

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,商家信息以实际为准,评测不代表权威。
该日志由 老左 于2019年04月04日发表在 WEB前端 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: WordPress安装需要PHP与MySQL版本要求与环境配置事项