WordPress 5.2版本将于四月底上线且最低需PHP 5.6.20版本

  1. 网友热度 11,423 ℃ - 抢沙发
  2. 标签:, ,
  3. 微信公众号: imweber

我们大部分个人网站、企业网站、自媒体以及内容型网站都会采用WordPress程序内核,确实提供的免费主题、插件以及文档是比较多的,而且源码方给予较多的技术升级支持。虽然前一段时间看到Gutenberg新款编辑器确实是比较难以接受,毕竟我们熟悉这么多年的传统编辑器,但是不可改变的是官方确实后面会主推这款编辑器。

根据官方提到的是必须在2021年的时候会强制使用Gutenberg编辑器,具体后面是不是可以替换传统编辑器,至少我们现在可以参考"WordPress5.0版本Gutenberg编辑器切换Classic Editor编辑器方法"继续使用传统编辑器。或者我们可以不用插件直接在Functions.php文件中加入以下代码实现禁止Gutenberg编辑器。

//禁止Gutenberg编辑器Laozuo.org整理
add_filter('use_block_editor_for_post', '__return_false');
remove_action( 'wp_enqueue_scripts', 'wp_common_block_scripts_and_styles' );

有点扯远了,今天这篇文章的目的是老左看到WP官方网站有提到在四月底会更新WordPress 5.2版本,且需要PHP最低支持需要5.6.20。如果我们服务器WEB配置是低于PHP5.6.20版本的,且后面软件升级之后需要升级的建议提前做好准备升级PHP。

我们看看官方是如何说的:

WordPress 5.2 is targeted for release at the end of this month, and with it comes an update to the minimum required version of PHP. WordPress will now require a minimum of PHP 5.6.20.

Beginning in WordPress 5.1, users running PHP versions below 5.6 have had a notification in their dashboard that includes information to help them update PHP. Since then, the WordPress stats have shown an increase in users on more recent versions of PHP.

WordPress 5.2版本将于本月底上线且最低需PHP 5.6.20版本

而且我们可以看到根据WP的官方文档中介绍到,最好的是升级至PHP7.3版本。所以,建议我们可以提前做好准备,比如在使用的插件或者主题是否兼容。不要到时候升级之后出现故障措手不及。对于服务器PHP版本的升级方法有很多办法,比如我们可以重新备份网站,然后重新配置新的WEB环境,或者是可以直接在服务器中安装多PHP版本进行切换。

1、OneinStack环境多PHP版本的安装共存与站点的设置

2、LNMP一键环境安装多PHP版本共存的方法

3、体验WDCP V3.2版本支持多PHP版本共存和SSL功能设置

这是老左之前在文章中有提到的多PHP版本的文章,后面我也会继续整理其他常用环境多PHP版本切换和更新方法。

本文固定链接: https://www.laozuo.org/13563.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。 公众号:imweber


关注公众号『站长事儿』

获取更多站长圈的新鲜事儿!
有您,有我,还有大家!

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,商家信息以实际为准,评测不代表权威。
该日志由 老左 于2019年04月02日发表在 老左杂谈 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: WordPress 5.2版本将于四月底上线且最低需PHP 5.6.20版本