解决WordPress升级导致PHP版本兼容故障 附最新WP软件要求

  1. 网友热度 157 ℃ - 抢沙发
  2. 标签:,

上午有同事告诉老左,在更新中的一个客户企业网站由于自己的误操作点击后台升级WordPress升级导致出现故障。于是老左让他将错误的提示问题发过来看看是什么。

Your server is running PHP version 5.4.45 but WordPress 5.4.2 requires at least 5.6.20.

可以看到提示的说明,因为当前的WordPress版本不兼容当前的低版本PHP。需要升级PHP才可以。这个问题老左以前也有遇到过,因为有些企业网站的客户仅仅是存放网站,确保可以打开即可,不需要运营推广的,所以不管他们。主要问题还是有些企业网站客户是自带过来的虚拟主机,本身PHP版本就比较老。

解决WordPress升级导致PHP版本兼容故障 附最新WP软件要求

我们可以看到当前最新的PHP版本是要求7.4,而且MYSQL是5.6,如果我们是PHP7.0还可以将就使用,但是也会提示要求升级PHP。所以,如果我们是虚拟 主机的话,你至少需要升级到5.6的PHP版本。如果我们是低于这个版本升级到WP最新版本就直接出现上面错误。

目前解决的办法是,我们去客户的企业网站所在的面板是否可以升级PHP,如果不可以升级只能将他搬迁到服务器中,因为我们大部分的服务器都是配置的PHP7.0+版本。看来以后的PHP需要7.4才可以,要不以后还是会麻烦。

本文固定链接: https://www.laozuo.org/17234.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。


关注公众号『站长事儿』

获取更多站长圈的新鲜事儿!
有您,有我,还有大家!

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,信息以实际为准,评测不代表权威。
该日志由 老左 于2020年10月16日发表在 WEB前端 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: 解决WordPress升级导致PHP版本兼容故障 附最新WP软件要求