解决WordPress博客无法安装插件的方法

  1. 网友热度 15,468 ℃ - 1条评论
  2. 标签:

今天在帮助公司搬家一个wordpress网站到VPS中,在后台升级某个插件的时候出现"要执行请求的操作,WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录"这样的提示错误信息。到底是什么问题呢?首先肯定想到VPS的权限问题,先赋予这个网站目录777权限,然后继续执行更新还是不能解决问题。难道真的要输入FTP信息才可以?

解决方法如下:在wp-config.php文件中,最后添加下面一句代码即可解决问题。

define("FS_METHOD", "direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);

不信大家试试吧。

本文固定链接: https://www.laozuo.org/825.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。


关注公众号『站长事儿』

获取更多站长圈的新鲜事儿!
有您,有我,还有大家!

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,信息以实际为准,评测不代表权威。
该日志由 老左 于2012年11月30日发表在 工具资源 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: 解决WordPress博客无法安装插件的方法