专注云服务商活动
网站运营运维笔记

建议建站选择哪个版本PHP?(PHP哪个版本好)

前几天国外的黑五和网络星期一活动促销商家看似比较多,但是实际上我们看到的也就那么几个。今天老左看到没有其他商家有特点的活动所以不准备发布促销活动信息,那就聊聊最近看到的有PHP8.0版本发布的信息。目前我们建站主流可能会选择PHP7.0+版本,但是前几天我们看到已经PHP8.0发布,而且官方也有进行对比测试也是有对比之前版本优势的。

实际上在我们很多有在建站选择云服务器之后配置WEB环境,有建站的时候肯定会选择PHP版本。比如我们早年使用PHP5.6版本、PHP5.3版本等都有,后来我们看到和听到PHP7+版本的性能会大幅度提高,于是我们也开始适应使用新的版本。那我们建站的时候选择哪个版本PHP呢?或者说我们建站PHP哪个版本好呢?这里老左谈谈自己的看法。

第一、选择程序版本指定的

虽然我们也清楚目前PHP7+版本性能比早年的版本优秀很多。但是我们有些老版本程序不兼容新版本,所以我们在建站选择的时候你还没办法选择新版本PHP。所以,我们在选择的时候,你只能二选一,你选择这个程序,你就只能根据程序建议适配的版本,如果你要选择高版本PHP,那你可能就要选择其他程序,或者更换适配。

第二、选择大众使用的版本

目前我们常用的版本是PHP7.3和PHP7.4,所以老左一般建议大家选择这两个版本。我们是否有发现,如果你选择PHP7.0的时候,在WordPress后台也有提示版本过低,希望我们提升至PHP7.3版本,当然这还需要看我们的主题,有些主题居然限制不支持高版本。

虽然我们不是程序高手,但是我们可以看到和听说高手的对比评测。且目前PHP8.0才上市还不成熟,肯定也有担心兼容问题,所以老左也不建议搭建在已有的生产环境使用最新版本。建议目前还是使用PHP7.3或者PHP7.4,当然也需要看我们程序兼容情况。

所以,在我们程序能运行的时候,肯定版本越高越好,要不官方开发新版本做什么呢?当然主要还是看我们的程序是否兼容。包括我们使用的插件和主题兼容情况。

赞(1)
未经允许不得转载:老左笔记 » 建议建站选择哪个版本PHP?(PHP哪个版本好)


扫码关注公众号

获取更多站长圈的新鲜事儿!
创业、运营、新知