解决安装xtrabackup出现"Header V4 DSA/SHA1 Signature"

  1. 网友热度 11,586 ℃ - 抢沙发
  2. 标签:

如果有需要安装xtrabackup工具的时候,其实最快的办法是直接用官方提供的rpm安装,反正在官方选择的时候要对应自己服务器的系统版本,不要安装centos的时候你选的是debian系统文件。在前面老左有记录到"解决安装XtraBackup出现"libev.so.4()(64bit) is needed"问题"问题,主要还是缺少必备的组件支持。

不过在继续安装的时候有出现"Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEY
error: Failed dependencies:"这样的错误提示。应该还是缺少必备的组件支持。

rpm -ivh percona-xtrabackup-24-2.4.9-1.el6.x86_64.rpm
warning: percona-xtrabackup-24-2.4.9-1.el6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEY
error: Failed dependencies:
percona-xtrabackup conflicts with percona-xtrabackup-24-2.4.9-1.el6.x86_64
[[email protected] ~]#

解决问题的办法我是采用网上找的需要必备的环境组件一咕噜全安装进去,然后再执行rpm安装的。

yum  install perl perl-devel libaio libaio-devel perl-Time-HiRes perl-DBD-MySQL -y

至少在遇到这个问题的时候通过此方法解决,如果我们还遇到问题可以再搜索其他解决方法。

本文固定链接: https://www.laozuo.org/11526.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。


关注公众号『站长事儿』

获取更多站长圈的新鲜事儿!
有您,有我,还有大家!

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,信息以实际为准,评测不代表权威。
该日志由 老左 于2018年01月31日发表在 主机教程 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: 解决安装xtrabackup出现"Header V4 DSA/SHA1 Signature"