专注云服务商活动
网站运营运维笔记

LNMP/LAMP一键脚本年度升级至V1.8 版本更新和选择须知

笔者个人还是比较喜欢选择LNMP脚本搭建Linux WEB环境的,虽然有些可视化界面上不如当前大家都有用的宝塔面板的,但是有些东西你习惯之后可能很难改变。而且我们也可以看到LNMP脚本,包括也可以安装LAMP每年6月1日更新大版本,今天跟新正式发布V1.8,如果我们有在使用的朋友可以升级或者新安装直接用最新版本。

LNMP/LAMP一键脚本年度升级至V1.8 版本更新和选择须知

但是,我们也不要麻木升级,根据LNMP更新日志可以看到,有些系统镜像和环境还是需要兼容性的,老左个人觉得,如果我们用这老版本还不如,那就不要升级。或者我们可以重新部署新版本然后迁移数据到新环境中。或者我们备份好后升级看看,如果没有问题那最好不过。

第一、LNMP升级V1.8办法

upgrade1.x-1.8.sh

如果我们原来是V1.7版本,升级到V1.8的话,直接用新工具包中的这个文件升级。但是一定要备份数据。有些过低版本的话,如果要升级最新版本,可能会出现问题。所以老左个人不建议升级,可以直接安装后迁移数据比较稳当。

第二、LNMP最新V1.8安装

wget http://soft.vpser.net/lnmp/lnmp1.8.tar.gz -cO lnmp1.8.tar.gz && tar zxf lnmp1.8.tar.gz && cd lnmp1.8 && ./install.sh lnmp

这里直接可以安装到V1.8,如果我们需要安装LAMP的话,那直接将最后的LNMP更换成LAMP即可。

第三、软件镜像选择须知

我们在选择镜像和软件版本的时候,需要注意是否和自己的系统镜像兼容。比如老左看到有人提到他还用V1.5版本,而且还用的CENTOS6,那你肯定是不能升级至V1.8的。我们需要重新用较新的镜像支持V1.8。具体我们可以看到官方须知。

最后再次提醒,升级软件的时候一定要先备份数据。

赞(5)
未经允许不得转载:老左笔记 » LNMP/LAMP一键脚本年度升级至V1.8 版本更新和选择须知


扫码关注公众号

获取更多站长圈的新鲜事儿!
创业、运营、新知