Debian9安装db4.8-util出现"Couldn't find any package"

  1. 网友热度 11,800 ℃ - 抢沙发
  2. 标签:,

今天老左有需要在Debian9系统中安装db4.8-util软件包,一般这个软件包都是直接在源中存在的,只要直接yum或者apt就可以安装。这里在尝试用到apt-get install db4.8-util去安装的时候出现报错Unable to locate package db4.8-util。

[email protected]:~# apt-get install db4.8-util
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package db4.8-util
E: Couldn't find any package by glob 'db4.8-util'
E: Couldn't find any package by regex 'db4.8-util'

Debian9安装db4.8-util出现"Couldn't find any package"

开始以为是源没有升级更新导致的,于是先apt update -y之后再安装也是这样无法解决。但是我还是觉得是源的问题,以为之前在其他服务器中的DEBIAN中是可以安装的,所以暂时不去直接编译安装,找个源升级。

这里想到"解决Debian环境无法update更新源问题及更换阿里云镜像",替换阿里云镜像。

第一、替换文件

vi /etc/apt/sources.list

第二、替换源内容

deb http://mirrors.aliyun.com/debian wheezy main contrib non-free
deb-src http://mirrors.aliyun.com/debian wheezy main contrib non-free
deb http://mirrors.aliyun.com/debian wheezy-updates main contrib non-free
deb-src http://mirrors.aliyun.com/debian wheezy-updates main contrib non-free
deb http://mirrors.aliyun.com/debian-security wheezy/updates main contrib non-free
deb-src http://mirrors.aliyun.com/debian-security wheezy/updates main contrib non-free

可以把sources.list先备份一份,然后我们将sources.list的内容全部替换成上面的阿里云源,然后再重新apt-get update -y之后可以完成更新。

第三、重新安装

apt-get install db4.8-util

这样问题解决。

本文固定链接: https://www.laozuo.org/12634.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。


关注公众号『站长事儿』

获取更多站长圈的新鲜事儿!
有您,有我,还有大家!

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,信息以实际为准,评测不代表权威。
该日志由 老左 于2018年10月26日发表在 主机教程 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: Debian9安装db4.8-util出现"Couldn't find any package"