解决WordPress后台提示"WordPress自动升级失败"问题

目前,我们大部分的网站都会使用的是WordPress程序,确实在应用上比较普遍。不过有些时候也有一些问题比较困扰一些新手站长。比如目前WordPress最新版本是5.7.2版本,但是如果有新版本出来的时候我们在登录WP后台的时候会看到类似"WordPress 5.7.2现已可用!请现在更新。"的提示。

遇到这个时候,我们会选择直接点击【现在更新】就可以实现自动更新。但是,有些时候确实存在问题,我们会通过手工更新的办法。不过,我们是否也有遇到我们的WP网站会自动更新,有的是能自动更新成功,有的却无法自动更新,而出现"WordPress自动升级失败"问题,这个说明系统检测且自动更新过,不过没有升级成功。

遇到这样的问题,我们只能去手工更新。

解决WordPress后台提示"WordPress自动升级失败"问题

这里我们需要登录服务器上我们的网站,先将wp-admin和wp-includes两个目录删除。然后我们需要将WP新版本中的这2个文件夹替换,这里需要注意wp-content文件夹还要保持原来我们自己网站的。

同时,WP新程序根目录的php文件也一并替换。完毕之后,我们登录:

https://www.laozuo.org/wp-admin/upgrade.php

红色字符换成我们的自己域名,然后直接升级即可。

所以,一般老左还是建议大家手工升级新版本。如果能自动那就不要管,不能的话,那就手工升级,不容易出错。当然,最新新手站长来说,还要注意备份数据。

关键字:,

本文固定链接: https://www.laozuo.org/19626.html | 老左笔记


声明:我们不销售主机,选主机需合法使用,信息以实际为准。


扫码关注公众号

获取更多站长圈的新鲜事儿!
创业、运营、新知

注意:任何主机需定期备份,防止数据丢失。主机需合法使用,信息以实际为准,评测不代表权威。
该日志由 老左 于2021年06月09日发表在 建站技术 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: 解决WordPress后台提示"WordPress自动升级失败"问题